iOS simulator won't work

Lars Brehmer larsbrehmer at me.com
Fri Oct 5 16:19:21 CDT 2012


Thanks for the reply Colin!

Unfortunately it still doesn't work!

> What are the chances!
> 
> Some things may have become more strict over time, and you may have to enter a more full app id.
> 
> In that field initially there is "com.yourcompany.yourapp", change that to something else, say "com.larsbrehmer.helloworldtest" If that then doesn't work, try selecting a provisioning profile.
> 
> What I think may have happened is that at the time I wrote those instructions the placeholder text was actually used as the app id, and so it worked. At some point RunRev may have intentionally removed that text when you do a test, so these days you have to enter your own id.
> 
> At least that's my guess, and I was able to see the problem you saw, and then get it to work by entering my own id, and selecting a provisioning file.


So I went through the provisioning process, which as everybody knows is quite lengthy. Still, the instructions were perfect and I have the valid certificate in my Keychain. 

The only remark about the process was the final step, which is opening your project in Xcode and doing something. Since I use liveCode and don't use Xcode, I simply skipped this step. 

So I have the certificate and it still won't work.

I still get the white icon, but nothing happens. The weird thing is that when I double click the home button on the simulator, that icon is there as if it is running.

Anyone experienced this and solved it?

Cheers,

Lars



More information about the use-livecode mailing list