Unable to install livecode on Linux, why?

Richmond richmondmathewson at gmail.com
Fri Jun 15 07:12:21 EDT 2012


On 15/06/12 11:04, Peter Alcibiades wrote:
> Yes, but it makes no difference how its tried.  The permission is set to
> everyone read and write, its also set to executable, and if I do it from
> thunar or from a terminal I get the same error.  I even started a terminal
> in the folder, became root, then started thunar as root, then tried to
> execute.  Thinking who knows what sort of error might be creeping in.  Same
> problem.  Weird or what?
>
> I can try on another machine, though we only have Debian installs around
> here...  I guess it would be possible to install fedora on a VM and then
> have a go there.

OK:

1. There should (nice modal verb there) be no problem with Debian and 
family, so
messing around with Fedora in VM is taking a long hike to nowhere 
particularly scenic.

2. As at work I can only hazard a few thoughts:

2.1. Last night I wondered about why I was having probs re Trial 5.5. 
and came to
the likely conclusion that it had something to do with me choosing 
'Custom Install'.
Unfortunately as this wondering was happening in bed with the cat 
sitting on my chest
I didn't get round to getting up, firing up the machine, and trying it out.

I have had this sort of prob once or twice before.

(I have yet to try to install Trial 5.5 with a plain, vanilla install)

Having said that: with RR/LC 3.5, 4.0 and 4.5 I have always gone for a 
custom install, putting everything
into directories in my HOME directory.

2.2. There may be a difference between the 4.5 beta 4 LC I generally use 
and your 4.5.3.

2.3. I ALWAYS have my ROOT and HOME on a single partition:

i.e. when I install Linux I partition my hard drive into 2 partitions: 
SWAP and EVERYTHING ELSE.

if you are 'being fancy' with your partitioning (while, possibly, being 
less vulnerable to funny things happening) this may be screwing up your 
LC installs.

3. LC 4.5 beta 4 installs a LOCKED folder; so everytime I have to copy 
its contents into a non-locked
folder before things begin to work.

>
> Peter
>
> --
> View this message in context: http://runtime-revolution.278305.n4.nabble.com/Unable-to-install-livecode-on-Linux-why-tp4650672p4650674.html
> Sent from the Revolution - User mailing list archive at Nabble.com.
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode






More information about the Use-livecode mailing list