Certain Images cause LC Freeze?

webmaster at curiositi.com webmaster at curiositi.com
Mon Jul 30 16:40:50 EDT 2012


Alejandro and Phil,

This is very curious.  I'm not sure why it works for you but fails 
every time for me.  Could you let me know if you are running LiveCode 
5.0.2 or something different for an IDE version?

Thank you so much for testing.  The support of the LC community is 
great!

--ForrestD


On Sun, 29 Jul 2012 21:03:33 -0700, Phil Davis wrote:
> Hi Forrest,
> It works fine here.
>
> Phil Davis
>
>
> On 7/29/12 7:42 PM, webmaster at curiositi.com wrote:
>> Sorry for the extra posts.  Since I can't upload, here is a URL to 
>> download the example stack.
>> http://www.curiositi.com/filestoshare/ImageCauseFreeze.zip
>>
>> Could some of you please download and tell me if you can recreate 
>> the error.  Any ideas for preventing this error?
>>
>> --ForrestD
>>
>>
>> On Sun, 29 Jul 2012 21:28:27 -0500, webmaster at curiositi.com wrote:
>>> Are file attachments allowed on this mailing list?  I'm attempting 
>>> to
>>> upload example stack as ZIPed file this time.
>>> --ForrestD
>>>
>>>
>>> On Sun, 29 Jul 2012 21:22:10 -0500, webmaster at curiositi.com wrote:
>>>> Have others encountered this problem before?  I've found that 
>>>> loading
>>>> certain images into a LiveCode Image Area cause the program to 
>>>> become
>>>> unresponsive.  I have to force quit LiveCode and upon relaunch 
>>>> "set
>>>> the filename" of the image area to empty.  Otherwise, it will lock 
>>>> up
>>>> again.
>>>>
>>>> Any ideas on why some images cause this lock-up, and others work 
>>>> just fine?
>>>>
>>>> I am attaching an example stack.  Here is how to recreate: (in Run 
>>>> mode)
>>>>
>>>> 1)  Click the "Load Image Area" button.
>>>> 2)  Click the "Go Next" button (or use keyboard shortcut)
>>>> 3)  Click the "Go Prev" button (or use keyboard shortcut)
>>>> 4)  Try to click anything... on the card or the tool palette --
>>>> nothing will work.
>>>>
>>>> Interestingly, you can perform the same steps with the same image
>>>> loading into a Quicktime Player control and not get a LiveCode 
>>>> Freeze
>>>> to occur.
>>>>
>>>>
>>>> I am running LiveCode 5.0.2 on Mac OSX 10.6.8.
>>>>
>>>>
>>>> Has anyone seen this before?  Any ideas on how can I prevent this
>>>> freeze/lock-up from happening?
>>>>
>>>> --Forrest Doddington
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your 
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>





More information about the Use-livecode mailing list