Heads up, don't use "secure" as a handler name

stephen barncard stephenREVOLUTION2 at barncard.com
Sat Sep 10 15:32:27 EDT 2011

this underscores our earlier disucssion that command and function names
never be the same as, and in some cases can't *contain* that name at all.

Naming convetions are very important. With a single namespace we have to
balance human readability with what won't confuse the compiler.

On 10 September 2011 13:04, J. Landman Gay <jacque at hyperactivesw.com> wrote:

> I had a function named "secure()" that's worked fine forever. It takes a
> text string as a parameter, processes it as SSL, and returns the secure
> string.
> As of LiveCode 4.6.4, "secure" is apparently an undocumented keyword. It
> not only throws an error and prevents scripts from compiling, it also
> prevents the script editor from populating its handler list. Basically it
> aborts whatever it touches.
> Changing the function name to "secureString()" fixed it. So just a heads-up
> in case you've got something like that in your code.
> --
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com

Stephen Barncard
San Francisco Ca. USA

more about sqb  <http://www.google.com/profiles/sbarncar>

More information about the Use-livecode mailing list