Standalones and Opening stack via go url...?

John Patten johnpatten at mac.com
Thu Oct 13 13:57:14 EDT 2011


FWIW...Solved it!

When creating a standalone, I used the default settings in regards to the "inclusions" which is to "Search for required inclusions when saving the standalone application." Having something work from the IDE but not from the Standalone means LiveCode apparently is not finding the right "inclusions." 

I set it the standalone settings to manually select  the inclusions. Then  I selected all inclusions from Animation through Printing, built my standalone, and then everything worked. Then I went back and selected just the original three, Geometry, Internet, and Printing and it worked again. 

It seems like the radio button that has LiveCode search for inclusions in the Standalone Settings does not always find correct inclusions. My guess is since it uses a go ULR "http://etc.etc... call it needs the Internet inclusion and was not getting it.

Seems from now on it's best to guess which inclusions are needed and select those manually if you have a project working in the IDE but not as a standalone? Is this a common issue?

Thanks!

John Patten
SUSD

On Oct 12, 2011, at 3:26 PM, John Patten wrote:

> Hi All!
> 
> I created a splash stack standalone that opens up a sub stack (Main App) stored in a local folder. From this stack, (Main App), I wish to open up a stack stored on a web server using the: go stack URL "http://www.server.com/mysubstack"
> 
> Here's the script I'm using in the Main App stack:
> 
> put cd fld 1 into tAction --(this holds the url address of substack)
>   put "go stack URL" & quote & tAction & quote into tAction  --(was having difficulty with quotes surrounding URL from web page to cd field, so did it this way)
>   do tAction
>   put specialfolderpath ("documents") & "/OneButtonOneField/" into tMainStack
>   put the short name of current stack into tCurrentStack
> save current stack as tMainStack & "/" & tCurrentStack
> 
> 
> This script works fine when everything is done in the IDE, however, when it runs from the standalone the second stack never opens the stack stored on the server. It also appears to save itself (Main App) as opposed to the stack I'm attempting to open???
> 
> Is what I'm attempting not possible in this fashion?  (standalone --> stack --> go url "http:...stack"
> 
> Thank You!
> 
> John Patten
> SUSD
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list