Strange Loss Of Focus

Terry Judd tsj at unimelb.edu.au
Mon Jun 27 19:11:42 EDT 2011


There must be something about your particular situation because copying a
group from a palette to a toplevel stack didn't interfere with a simple
mouseMove handler in the palette stack for me, irrespective of whether it
was initiated from the palette stack or the toplevel stack.

I guess it's no better than using the click command, but does focusing on a
particular control on the palette stack after the copy also bring the
palette back into play?

Terry...


On 28/06/2011 08:31 AM, "Scott Rossi" <scott at tactilemedia.com> wrote:

> The message title would normally refer to me, but in this case, the problem
> is with a stack...
> 
> I have a palette stack that initiates copying of groups from one stack to
> another.  Once the copy is done, the palette stack apparently loses focus,
> and a mouseMove handler in the palette refuses to trigger unless the mouse
> moves in and out of the stack's rect 2 times.
> 
> I've started using a workaround (?) that sends a physical "click" command to
> the palette after the copy operation finishes, to try to physically activate
> the palette again.  It seems to be working, but this is kind of goofy and
> I'm wondering if there's a better way to make the palette's mouseMove
> detection responsive again.
> 
> Thanks for any suggestions.
> 
> Regards,
> 
> Scott Rossi
> Creative Director
> Tactile Media, UX Design
> 
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> 

--
Dr Terry Judd | Senior Lecturer in Medical Education
Medical Education Unit
Melbourne Medical School
The University of Melbourne







More information about the Use-livecode mailing list