iOS SDK config problems

Terry Vogelaar tvogelaar at de-mare.nl
Sun Jun 26 01:02:48 CDT 2011


I was delighted to see the LiveCode iOS externals SDK ship, and to see an instruction video on the RunRev channel to help me get started. I expected to run into problems with starting to write my own Objective C code, but I actually ran into problems much sooner. So I might need some help.

What I have installed is: the DP4 of Lion, LiveCode 4.6.2, the iOS Externals SDK, Xcode 3.2.6 and iOS SDK 4.3. And with this configuration, I cannot use the test button in the LiveCode toolbar. So I went to the Preferences, and under Mobile Support, I tried to reset the 'Location of developer root for iOS 3.2 and above'. It was set to /Developer, which should be right. But when I choose that folder again, I get an error: "The chosen folder is not a valid iOS SDK for 3.2 and later. It must be the one that ships with XCode 3.2.4 or later." 

Bummer! It might be because of Lion. So I restarted from my bootable clone I made before upgrading to Lion and I installed LiveCode 4.6.2 and the Externals SDK on it. So now I have almost the same config, but with the newest Snow Leopard instead of Lion.

That was better. Testing on the iPhone Simulator worked as expected. So I started following along with the instruction video, but near the end of it, the instructor chose "iPhone Simulator" from the pulldown menu. That option wasn't available for me. Over here, it reads "Base SDK Missing" on that same pulldown menu. I did some googling on that, but I was unsuccessful in solving it.

What am I doing wrong? 

Terry


More information about the use-livecode mailing list