Test on android simulator

Mark Schonewille m.schonewille at economy-x-talk.com
Sun Jun 19 12:54:01 EDT 2011


Hi Jacque,

I think you mean

./adb devices

and this command doesn't show any of the virtual devices, even if LiveCode does see these virtual devices. The question is about the simulator, not about an actual tablet.

--
Best regards,

Mark Schonewille

Economy-x-Talk Consulting and Software Engineering
Homepage: http://economy-x-talk.com
Twitter: http://twitter.com/xtalkprogrammer
KvK: 50277553

New: Download the Installer Maker Plugin 1.6 for LiveCode here http://qery.us/ce

On 19 jun 2011, at 18:44, J. Landman Gay wrote:

> On 6/19/11 1:44 AM, Ludovic Thébault wrote:
>> Hello,
>> 
>> I've installed the android SDK. It's works. i've create an virtual
>> device. It's works. I've set the "mobile configuration" in prefs to
>> put the path of the sdk. I've the "jdk" path displayed.
>> 
>> But in the Test target menu of livecode (461), i've nothing about
>> Android...
>> 
>> What is wrong ?
> 
> When it happens to me, it means that the device is not mounted correctly in debug mode. LiveCode will see any device if the adb tool does. Open a new terminal window, cd to the platform-tools folder and type:
> 
> adb devices
> 
> If that command does not list the serial number of your device, then LiveCode can't see it either. You'll need to make sure that adb tools recognizes it before you can use the LiveCode interface.
> 
> I have never had LiveCode fail if adb can see my tablet. But I have had many occasions where adb can't see my tablet. Sometimes I need to reboot it after turning on debug mode.





More information about the Use-livecode mailing list