Object Prefixation

Richmond richmondmathewson at gmail.com
Fri Jan 21 14:12:02 EST 2011


On 01/21/2011 08:55 PM, Mark Wieder wrote:
> Richmond-
>
> Friday, January 21, 2011, 10:48:43 AM, you wrote:
>
>> "fldTEXT" is a field
>> "grfPIC" is a graphic
>> "grpGROOP" is a group
>> "imgIMAGE" is an image
>> "btnKOPCHE" is a button
>> and so on?
> I regularly use all those except I use "grc" for graphic. ymmv. Also
> "lblTEXT" for label fields, *especially* when I have an associated
> label-textfield pair, in which case I name them similarly:
>
> "fldEmailAddress"
> "lblEmailAddress"
>
  "Somebody " [not me, buster; somebody nearer the centre; not, like 
myself, off on the
outer arm of the lesser spiral galaxy] should draw up a semi-official 
set of these things
and present them as a downloadable PDF somewhere [hey; how about on the 
RunRev
site].

I am not am huge fan of comformity ["Really; you surprise me, Mr 
Mathewson:]; however,
there is a time and a place for everything; and this might just be one 
of those junctures
that would benefit from some sort of conformity.



More information about the Use-livecode mailing list