Cursor lock

Bob Sneidar bobs at twft.com
Tue Jan 18 17:23:11 EST 2011


Let's start looking for common things. Anyone using an alternate debugger? An alternate script editor? How about everyone having this problem remove all add-ons and start up LiveCode again and see if it persists. Sorry, I'm a troubleshooter. 

Bob


On Jan 18, 2011, at 2:15 PM, Björnke von Gierke wrote:

> I had this several times. the script editor also often gets stuck on resize mode, despite the mouse being clicked on the field or another object that is not the resize triangle.
> 
> just now the script editors backgroundcolor was set to white when i opened it, and the mosue was stuck at the pane-resizing icon (two paralell lines with arrows pointing left and right). had to change tool for the cursor, reopen editor for the background color.
> 
> On 18 Jan 2011, at 21:47, J. Landman Gay wrote:
> 
>> On 1/18/11 12:52 PM, Richmond wrote:
>>> On 01/18/2011 08:31 PM, J. Landman Gay wrote:
>>>> Is anyone else having trouble with the cursor not updating, or
>>>> sometimes locking, in version 4.5.3? I'm noticing it particularly in
>>>> the script editor, where the cursor doesn't change when you mouse over
>>>> different panes or outside the window.
>>>> 
>>>> I'm also noticing that sometimes clicking on a window doesn't activate
>>>> it. The message box doesn't update to show the stack name and the
>>>> window titlebar remains disabled.
>>>> 
>>>> Just trying to figure out if it's me with a stray "lock messages"
>>>> command somewhere, or if I can blame it on someone else.
>>>> 
>>>> OS X Snow Leopard.
>>>> 
>>> 
>>> Down in the undergrowth [i.e. RR 4.0 on a PPC macMini running Tiger] the
>>> cursor suddenly
>>> turns into what I like to call "the Clariswork clock", or, more
>>> accurately " the Mac OS 7 clock"
>>> and gets stuck like that.
>> 
>> If you mean the rainbow beachball, that's a different thing. Judging from the lack of response, it must be something in my setup. All I can think of is a stray "lock messages" command, but those are supposed to reset at the end of pending handlers and that isn't happening. But if the problem were widespread I guess there'd be all kinds of reports about it. It's incredibly irritating.
>> 
>> And here I was hoping it wasn't my fault.
>> 
>> -- 
>> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>> HyperActive Software           |     http://www.hyperactivesw.com
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list