ios image file names.

Andrew Henshaw henshaw at me.com
Sun Dec 11 16:41:46 EST 2011


If you run the mac console app this will output simulator errors or 'put' messages in your code,  or if its a device you can track the messages in xcode.  Paths are pretty specific,  I find keeping everything lower case really helps.

Some really useful code someone posted a while back is using the errorDialog if you are not using it already as the iOS engine can happily discard errors and plod on,  but adding the following lines to the main stack can often find problems really quickly....

on errorDialog pExecutionError, pParseError
      if item 2 of line 1 of pExecutionError is 0 then 
             answer "An error occurred " & cr & cr &  pExecutionError
         else
             answer "An error occurred on line: " & item 2 of line 1 of pExecutionError 
       end if
end errorDialog

I comment them out when its ready for a final release,  but during the debug stages they can be life savers!

As for (2),  ive had the same issue for a while and from memory its not one Runrev managed to replicate.  All I do after the first time i use the simulator is as soon as I click test,  I then click on the simulator window and it loads quickly without the warning.  If its the first time I just click on the simulator and ignore the warning!

Andy



On 11 Dec 2011, at 19:55, edward cawley wrote:

> Two problems.
> 1. I've got a problem with image file names. I am developing an app of plant descriptions. It has 42 cards, one for each plant species. Each cd is the same template, the text and images are the only things that change. 40 of the cards work fine but two have a problem with small movies/video clips they don't show but the player is working. The messages are halted for the time the clip should run. I discovered one was stopped because I had a upper case letter in the file name and not in the icontrolset  command. Changed the filename( dropped the uppercase letter) and it solved the one problem,  but the last cd is still not working. I'm pretty sure it is the same type of problem but how can I see what is happening in the simulator, what is it downloading? I can't check it on the desktop since I get an execution error on the ios control command?
> 
> 2. Slightly different problem, if I start to test the app on the simulator by clicking on the simulator in the menu bar it begins to startup, the simulator shows up and then I get a dialog stating the the app is taking a long time to start up,at that point the app appears and another dialog appears asking if I wish to continue trying or stop. If I click on stop the simulator closes and if  I click on yes the dialog box continues to try to start up, even though the app is up and running. If I start  up the simulator first and then click on the menu from the desktop app the app starts on the simulator with no problem. Is this a bug or is it the sequence we are supposed to use? I don't remember seeing it in the documents.
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list