Android's mobileDeviceInfo

Maarten Koopmans maarten.koopmans at gmail.com
Thu Aug 25 01:58:14 EDT 2011


Thanks, but tried that, no result. The "ask" was a slip of the mind while
typing. Can anyone confirm that mobileDeviceInfo doesn't work (best tested
on actual device) before I file a bug report?

--Maarten

On Thursday, August 25, 2011, J. Landman Gay <jacque at hyperactivesw.com>
wrote:
> On 8/24/11 9:03 PM, Maarten Koopmans wrote:
>>
>> Hi,
>>
>> If you look in the Android release notes ( p27) you'll see a function
>> mobileDeviceInfo. I've tested it like this:
>>
>> on mouseUp
>>   ask mobileDeviceInfo("DISPLAY") with "OK"
>> end mouseUp
>>
>> with a simple Android stack and one button. Also tried other fields like
>> HOST (the one I actually need) and ID. Neither the simulator, my Samsung
>> Galaxy S or my HTC Flyer show a dialog. Asking just a static string works
>> fine.
>
> Do you mean "answer"? "Ask" is for getting user input. The way it's
written above, the device info would be shown as the prompt. In either case,
apparently the engine isn't evaluating the function.
>
> If "answer" also doesn't work, try moving the function outside of the
answer command, like this:
>
> put mobileDeviceInfo("DISPLAY") into tDeviceInfo
> answer tDeviceInfo
>
> --
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list