[HELP] Facing a datagrid bug

Andre Garzia andre at andregarzia.com
Tue Aug 16 11:04:47 EDT 2011


Folks,

I am consistently facing a strange bug with the datagrid in 4.6.x in more
than one project. I don't have an exact recipe but I can explain how it
works. I have a datagrid that mimics a table. I am just placing text in
there. Some text columns will have content on just some fields and this
content may have some unicode characters such as accents of some symbols
such as that superscript "o". When clicking the column header to sort the
column, the datagrid will display an dialog box saying error in the script
and die. This happens just for some columns but it is happening in three
projects. It is really hard to debug but I believe it is related to the
routine that sorts the datagrid, I think that down inside that function,
some comparision command fails and the error bubbles up from there.

Anyone seeing something similar?

This is happening here in three different projects all related to database
frontends. I have a card with a list of records. When for example I click
the header of column "Title", it will fail and die. I don't know why. The
datagrid should not fail like that. The array used is a really big one maybe
a megabyte or two worth of information. It is basically text but it may
contain unicode characters. I am using that unidecode trick from the
documentation, the data appears fine in the datagrid.

Also, why can't we override the sorting routines?

Cheers
andre

-- 
http://www.andregarzia.com All We Do Is Code.



More information about the Use-livecode mailing list