bizarre problem, big emergency!

Lars Brehmer larsbrehmer at
Tue Aug 9 15:07:49 EDT 2011

I have a stack/standalone that I have been working with for months. Suddenly I cannot open it in Rev (2.8) and the standalone won't launch either!

To make things clear: the standalone is a splashscreen stack that contains several compressed stacks as custom properties. When the standalone launches, or the splashscreen stack launches in Rev, it looks for the other stacks in (on a Mac) in users/myUserName/library/preferences/myPreferenceFolder. If the stacks are not there, the compressed stacks in the custom properties of the splashscreen stack are decompressed and placed into the preference folder. Changes made to them are saved there.

This has worked for many months - using either the standalone or opening the splashscreen stack in Rev.

Suddenly the standalone won't open (it bounces once in the dock and then nothing) and the splashscreen stack won't open in Rev - Rev simply quits, no warning, no error message, nothing!

When I work on this app in Rev and make changes (to the stacks in the preferences folder) and save, those stacks in the preferences folder are compressed and they replace the compressed stacks in the custom properties of the splashscreen stack. Everything always up-to-date.

I have never encountered this problem before. Everything has always worked as expected.

The stacks that are stored in the preferences folder can all be opened in Rev no problem. But the splashscreen simply won't open either as a standalone or in Rev. This of course means that I can't open the stack in scriptDebug mode and find the problem.

I have tried to restore an earlier version of the stack using Time Machine, but all previous versions that always worked at the time behave the same way - Rev quits, no error message, nothing. The really weird thing is that I have a copy of that splashscreen stack that is 2 months old and has never been opened, but it won't open either!!!! Even though it is a copy of the original which opened at the time and has always opened ever since until today!

I have done the following to try to solve this; I trashed the Rev prefs, ran Cocktail and restarted. I have tried several earlier versions (using time machine) from days that definitely worked properly at the time. `None of them work! Even if they did work, it doesn't explain why a standalone that always worked before doesn't work now!

I can't think of anything else to try. Any suggestions????



More information about the Use-livecode mailing list