LC and OS X version compatibility

Ken Ray kray at sonsothunder.com
Mon Aug 8 09:29:59 EDT 2011


On Aug 8, 2011, at 4:24 AM, Tiemo Hollmann TB wrote:

> Hello,
> 
> the LiveCode release notes say about system compatibility for:
> 
> LC 4.5.0: Mac OS X 10.3.9 to 10.6.x
> 
> LC 4.6.0: Mac OS X 10.4.11 to 10.7.x
> 
> Does anybody knows if there are any trouble with LC 4.5 on 10.7 lion?

No, I haven't had any trouble.

> Is LC 4.6. not working on 10.3. anymore in general, or does it concern only
> some new features?

I'm pretty sure it doesn't work at all; I know for sure that even Rev 3.5 had issues under 10.3 (drawers didn't work right for example).

> How widespread is OS X 10.3 still out there in the wild? Do you still take
> care about panther or is it no question about to use today 4.6 and kick off
> panther compatibility?

It may just be here in the States, but I'm seeing virtually no one using 10.3; the earliest OS I've encountered with my clients and their customers has been 10.4.11. Personally I have been targeting 10.4.11 or higher ever since 10.6 came out, and that hasn't given me any problems.

Ken Ray
Sons of Thunder Software, Inc.
Email: kray at sonsothunder.com
Web Site: http://www.sonsothunder.com/	




More information about the Use-livecode mailing list