Weird cursor freeze

J. Landman Gay jacque at hyperactivesw.com
Tue Apr 12 20:05:33 EDT 2011


On 4/12/11 4:48 AM, David Glasgow wrote:
>The script runs fine but then the cursor freezes in
> position, and displaying as whatever icon was last set.  Oddly, the
> cursor is locked in the same place in all open apps, so switching
> between finder etc. and LC doesn't help.  Using shortcuts to switch
> in and out of browse/edit mode doesn't work.  The only way out I have
> found in the dev environment is to invoke the preferences stack via
> shortcut, and THEN switch between browse and edit mode via keyboard.
> This allows the cursor to move, but it sticks with whatever icon was
> set until it feels like changing for no obvious reason, although
> sometimes in response to a command.  I have tried various cursor
> related commands within the "finish" handler, all of which appear to
> be executed correctly, but always followed by the system wide cursor
> lock up.
>
> Running the debugger prevents the problem arising, so it isn't much
> help.  Sadly, the problem isn't restricted to the dev environment,
> and I have to force quit standalones on Mac.  All this is on Mac,
> running LC 4.0 and 4.5 Could it be a problem with the mac cursor
> stack?  If so, how should I set about exploring that possibility?

As a guess, it sounds like you have a script running that isn't yielding 
time to the engine. Cursors don't update until all pending handlers have 
finished. If you have something going forever in the background, there 
won't be any idle time in which the engine can do cleanup.

You could try adding a "wait 1 with messages" here and there to see if 
that fixes it. A better approach would be to find out what's preventing 
the engine from getting any idle time.

Specifically setting the cursor should have worked though, so I'm not 
sure what could be going on. I'm just jumping in because no one else did.

-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com




More information about the Use-livecode mailing list