Question about the debugger in Rev 4.0

Jim Ault jimaultwins at yahoo.com
Wed Sep 8 16:10:30 CDT 2010


On Sep 8, 2010, at 1:54 PM, Bob Sneidar wrote:

> Hey! I was having that exact problem with GLX2 (which I still use  
> and love btw). I thought it was an incompatibility with Rev 4. Are  
> you saying you never used GLX2 and you are still having the  
> problem?? My problem was at times related to the fact that sometimes  
> debug mode would turn itself off. Not sure if this was after a save  
> (it seemed to be) or if the process of stepping into code somehow  
> disabled it on the next execution. Still, there have been times I  
> have checked and a breakpoint was ignored, but debugging was  
> definitely on.

>
> Bob
>
Correct.  Execution does not stop once I have added a character to the  
code and compiled.  Saving does not seem to have any effect.
I have not installed GLX2 or any other code editor or debugger.


> On Sep 8, 2010, at 9:52 AM, Jim Ault wrote:
>
>>
>> I have been using version 4.0 for about 2 months and find one thing  
>> very annoying, that does not happen in version 3.5
>>
>> When I set a breakpoint in the margin that appears as a red circle,  
>> then run the handler, the breakpoint works as expected.  If I make  
>> a change in the code on a different line, then run again, the  
>> breakpoint is ignored.
>>
>> The circle is still red, and the breakpoint pane shows that it is  
>> active, but it is still ignored.
>>
>> The only technique I found to work is to turn off the break, then  
>> turn it on again.  This is very cumbersome when there are a few  
>> breaks along a sizable handler, since that involves scrolling up  
>> and down to reset them.
>>
>> Is there a preference to set?
>>

Jim Ault
Las Vegas






More information about the use-livecode mailing list