Data Grids Stop Working

Bob Sneidar bobs at twft.com
Wed Nov 24 12:50:38 EST 2010


It would be interesting to know what vTheList contained at the time of the error. Also, (and I know it sounds too simple) but are you sure the name of the data grid has not changed? 

Now the line you show below would be one you would execute outside the datagrid itself. If this is something inside the datagrid, you should use the form "of me" (assuming it's in the datagrid behavior script). Not saying that is the problem, but I would start looking at the simple things. 

Bob


On Nov 23, 2010, at 9:04 PM, Paul Looney wrote:

> Many times, on many stacks, data grids have simply stopped working - without any warning or error.
> The line of code they fail to execute is this, or similar:
> 
>   set the dgText of grp "Data Grid" to vTheList
> 
> The code may have worked for months before is fails.
> The only solution I've found is to delete the existing grids and replace them with new ones. Doing so, without any code changes, fixes the problem.
> I don't have a recipe. But, so far, the problem has only come up while working in the IDE.
> It has appeared on different computers (all Mac), with different OSes (OS X 10.4.11 through OS X 10.6.4) and assorted versions of Rev/Livecode (4.0 through 4.5.1).
> Advice/suggestions appreciated.
> Paul Looney
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list