Hypercard stack quits before opening solved

Shari shari at gypsyware.com
Mon Nov 22 08:07:32 EST 2010

I no longer have Hypercard, or a computer system that supports it. 
Lightening took that computer out, so it is not possible to open them 
in Hypercard to compress.

I had created several shareware games in Hypercard just before it 
went defunct and it was awhile before I took the plunge to Metacard. 
I kept waiting, as did we all, for Apple to change their minds and 
move forward but they never did.

It was overwhelming to have everything I'd created "break" when Apple 
came out with OSX.  While I had originally intended to move them all 
forward in Metacard, one sort of took over and became almost a full 
time thing and the others languished.  People kept asking for more 
features so I focused on that program.  Hence the long delay in 
moving the rest of the stacks forward.  I assumed that 
Metacard/Revolution would handle it when I was ready and I wasn't 
sure I was even going to do it so they sat.

I am now, very belatedly, moving one of the others forward.  I've 
already revamped the graphics.   No way to access it in Hypercard 
anymore.  If it weren't for my old old version of Metacard, I don't 
know if it could be accessed, if there is a trick in Revolution to 
open the old Hypercard stacks.

It's been a challenge because the documenation for the game was in an 
application called DocMaker, also now defunct, and I had not saved it 
in a friendlier format.  But I found a way into that too. 
Procrastination does come back to bite us!

Not everyone with old Hypercard stacks would necessarily have the old 
Metacard to open them.  I've found my solution, but I do wonder about 
other folks in the same boat.


>On 11/19/10 5:53 PM, Shari wrote:
>>Solved the problem before posting but will post it anyway in case anyone
>>else encounters it.
>>I've got an old hypercard stack that I can't get into. Rev quits
>>immediately when I try to open the stack. I also tried creating a
>>different stack, and then "edit the script of stack xyz" to see if there
>>were something I could override causing it to quit but that quits too.
>>Any suggestions?
>I answered but saw that the reply address has changed, so my first 
>reply will show up on the new list when it appears.
>But what I said was that this is a common symptom of uncompressed HC 
>stacks. If you first open the stack in HC and compress it twice, any 
>Rev/LC engine will usually open it.
>What changed wasn't the HC import, I don't think, but the way the 
>engine deals with the imported stack. The file format changed in Rev 
>2.7 and that may have made a difference.
>Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>HyperActive Software           |     http://www.hyperactivesw.com
>use-livecode mailing list
>use-livecode at lists.runrev.com
>Please visit this url to subscribe, unsubscribe and manage your 
>subscription preferences:

Bad Dog Books
Critters, humor, patriots and sports t-shirts
  WlND0WS and MAClNT0SH shareware

More information about the use-livecode mailing list