Strange behavior in the IDE

Andrew Kluthe andrew at rjdfarm.com
Wed May 19 21:10:44 EDT 2010


Hello all. 

Last night I built a splash loader for my application that loads sqlYoga,
negotiates the database connection and opens up all the stacks needed for my
program.

Well, I wake up today and the revIDE has been extremely erratic! Last night
the loader ran as it was supposed to, it worked very well with StackRunner
2.0 from sons of thunder as well. Today, it works exactly the same when
opened with StackRunner but the rev IDE doesn't load it correctly. No
messages get sent when watching the message watcher. The only way I can get
the rest of the script to execute is to choose "Close and remove from
memory" several times until it finally (seemingly at random) loads properly. 

I have noticed some other strange behavior such as my SQLYoga object loses
the schema for my db. When this happens closing and re-opening the IDE is
the only thing that can try to fix it. All the while, these same stacks work
flawlessly in StackRunner 2.0

I tried re-installing revEnterprise, and installing revEnterprise to another
directory. Is this a problem with my code or something else entirely? I may
have copied my sqlButton containing my SQLYoga Object to another stack along
with the code that invoked it. Would this cause this sort of problem? I am
at a loss for what to do. It wont really let me develop anymore without
these very very large quirks. 

Any help or shared experience would be greatly appreciated. 

Learning revTalk while developing an app with it has left my program in a
state semi-disarray and chock full of code revisions and refactoring. I am
tempted to recreate what I have from the pool of spaghetti code. I am
thinking this will take less time than cleaning up the code and debugging
it. Thoughts on this?
-- 
View this message in context: http://runtime-revolution.278305.n4.nabble.com/Strange-behavior-in-the-IDE-tp2223808p2223808.html
Sent from the Revolution - User mailing list archive at Nabble.com.



More information about the Use-livecode mailing list