AW: need advice for keeping file flags in a zip

Tiemo Hollmann TB toolbook at kestner.de
Tue May 4 06:47:23 EDT 2010


Hello,

after another Test, Thierry could reproduce the described behaviour that you
can't keep the locked flag (uchg) of a file when zipping it with PKzip. So
perhaps anybody can confirm either if it is a standard behavior/feature of
OSX 10.5/10.6 or it's a bug of OSX? Because I don't find any hints
googeling, I almost think it is standard, but why?
Test:
A folder containing a file with the locked flag.
Zipping it, e.g: ditto -c -k --sequesterRsrc SrcFolder  testditto.zip
Unzipping it and the locked flag is gone
Thanks
Tiemo


> -----Ursprüngliche Nachricht-----
> Von: use-revolution-bounces at lists.runrev.com [mailto:use-revolution-
> bounces at lists.runrev.com] Im Auftrag von Tiemo Hollmann TB
> Gesendet: Montag, 3. Mai 2010 08:54
> An: 'How to use Revolution'
> Betreff: OT: need advice for keeping file flags in a zip
> 
> Hello,
> 
> still struggeling with keeping the locked flag of a file when zipping
> and
> unzipping. I followed exactly Thierries advice to use following syntax:
> 
> ditto -c -k --sequesterRsrc SrcFolder  testditto.zip
> 
> and though a locked file in Thierries environment is still locked after
> unzipping, in my environment (MacOS 10.5.8) the file isn't locked
> anymore
> after unzipping. So the difference must be in any other test parameter.
> What
> I have tried is following:
> 
> -          Actually I am not sure, if the flag gets lost while zipping
> or
> unzipping. Anyhow, after unzipping, controlling the information of the
> file,
> the flag is lost
> 
> -          I tried different zip tools for zipping and unzipping
> (ditto,
> 7zip, gui tar) with same result
> 
> -          Originally my locked file resides within a bundle, but I
> tested
> also with a single locked testfile in the source folder with same
> result
> 
> -          I tested different compression formats (zip, CPIO) with
> ditto
> with same result
> 
> -          When using the ditto option -v (just copying a file) the
> locked
> flag is kept, but not with -c (creating a compressed archive)
> 
> -          I also tested the ditto options: ditto -c -k --rsrc  --
> extattr
> SrcFolder testditto.zip with same result
> 
> So it seems like my problem isn't the zipping and I am overlooking
> something
> obvious outside the zipping process. My Mac knowledge is so small, that
> I
> really stuck here, what could cause such a different behavior: OS
> version,
> User permission (I have full rights), ditto handling,.?
> 
> Any advice appreciated
> 
> Tiemo
> 
> 
> 
> 
> 
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the Use-livecode mailing list