OT: need advice for keeping file flags in a zip

Tiemo Hollmann TB toolbook at kestner.de
Mon May 3 01:54:12 CDT 2010


Hello,

still struggeling with keeping the locked flag of a file when zipping and
unzipping. I followed exactly Thierries advice to use following syntax:

ditto -c -k --sequesterRsrc SrcFolder  testditto.zip

and though a locked file in Thierries environment is still locked after
unzipping, in my environment (MacOS 10.5.8) the file isn't locked anymore
after unzipping. So the difference must be in any other test parameter. What
I have tried is following:

-          Actually I am not sure, if the flag gets lost while zipping or
unzipping. Anyhow, after unzipping, controlling the information of the file,
the flag is lost

-          I tried different zip tools for zipping and unzipping (ditto,
7zip, gui tar) with same result

-          Originally my locked file resides within a bundle, but I tested
also with a single locked testfile in the source folder with same result

-          I tested different compression formats (zip, CPIO) with ditto
with same result

-          When using the ditto option -v (just copying a file) the locked
flag is kept, but not with -c (creating a compressed archive)

-          I also tested the ditto options: ditto -c -k --rsrc  --extattr
SrcFolder testditto.zip with same result

So it seems like my problem isn't the zipping and I am overlooking something
obvious outside the zipping process. My Mac knowledge is so small, that I
really stuck here, what could cause such a different behavior: OS version,
User permission (I have full rights), ditto handling,.?

Any advice appreciated

Tiemo

 

 




More information about the use-livecode mailing list