Drag and Drop on revBrowser...

Simon Lord slord at karbonized.com
Thu Jun 24 16:36:01 EDT 2010


What I meant by *nothing* is that even the browserNavigateComplete is
only sent/registered if the mouse exits the revBrowser.  If I don't
move the mouse, or I stay with the revBrowser then the messages get
queued up.  When I exit the revBrowser I get a few dozen beeps and url
refreshes.  This feature is surely broke.

on browserNavigateComplete pId, pUrl
   beep
   forceRefreshURL
end browserNavigateComplete





On Thu, Jun 24, 2010 at 4:30 PM, Simon Lord <slord at marelina.com> wrote:
> I even have a beep message being sent.  Nothing.
>
> I also tried to capture the browserClick but it never works.  At all.
>
> I'm running 10.6.4—this is starting to smell like a bug I cannot work around.
>
>
> On Thu, Jun 24, 2010 at 4:15 PM, Jerry Daniels <jerry.daniels at me.com> wrote:
>> Works every time here. What OS? You're sure your cursor-move code is executing each time.
>>
>> Admittedly, a complete hack of a solution. Shameful, really. Ok, I'm over it.
>>
>> Best,
>>
>> Jerry Daniels
>>
>> Follow the Rodeo discussion:
>> http://rodeoapps.com/rodeo-discuss-among-yourselves
>>
>>
>>
>> On Jun 24, 2010, at 3:11 PM, Simon Lord wrote:
>>
>>> Tried that.  Odd that it works for you.  It only works the first time
>>> for me, every subsequent link still refuses to update the URL until
>>> the mouse exits the revBrowser.
>>>
>>>
>>>
>>> On Thu, Jun 24, 2010 at 4:05 PM, Jerry Daniels <jerry.daniels at me.com> wrote:
>>>> Simon,
>>>>
>>>> I ran into this with Rodeo's built-in browser and I found a way to make my URL field update after navigating to another page--which sounds a lot like your problem.
>>>>
>>>> put the mouseScreenLoc into tLoc
>>>> set the mouseScreenLoc to the topleft of this stack
>>>> set the mouseScreenLoc to tLoc
>>>>
>>>> This was on Mac Snow Leopard. I could not tell the cursor was moved and my URL field updated immediately. I did ran this cde within the browserNavigateComplete message. handler
>>>>
>>>> HTH
>>>>
>>>> Best,
>>>>
>>>> Jerry Daniels
>>>>
>>>> Follow the Rodeo discussion:
>>>> http://rodeoapps.com/rodeo-discuss-among-yourselves
>>>>
>>>>
>>>>
>>>> On Jun 24, 2010, at 1:09 PM, Simon Lord wrote:
>>>>
>>>>> So the issue of not updating the URL until the mouse leaves the
>>>>> revBrowser is a bit of a pain.  When I drag an image from the desktop
>>>>> to the stack the image immediately pops up in the browser as expected.
>>>>> But the URL doesn't upload until the mouse is *outside* the bounds of
>>>>> the browser.  Since the mouse *must* be within the bounds to drop the
>>>>> image it means this is a fairly repeatable bug.
>>>>>
>>>>> Is there any way to detect a drag&drop on the revBrowser so I can
>>>>> force a URL refresh?
>>>>> _______________________________________________
>>>>> use-revolution mailing list
>>>>> use-revolution at lists.runrev.com
>>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>>>
>>>> _______________________________________________
>>>> use-revolution mailing list
>>>> use-revolution at lists.runrev.com
>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>>>
>>> _______________________________________________
>>> use-revolution mailing list
>>> use-revolution at lists.runrev.com
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>
>> _______________________________________________
>> use-revolution mailing list
>> use-revolution at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>
>



More information about the Use-livecode mailing list