Mac standalones (Rev 4.0) don't run under Jaguar (10.2.8)

Chris Sheffield cmsheffield at gmail.com
Tue Jun 15 11:53:09 CDT 2010


Not sure if anyone out there is even still supporting Jaguar with their apps, but we are (schools tend to take forever to upgrade equipment/operating systems). We are in the process of doing an update to our software. We switched to Rev 4.0 for this update in order to fix a few bugs. Unfortunately, it's looking like standalones built with Rev 4.0 do not run under Jaguar. We're getting the infamous bouncing icon in the dock and then it crashes. Is anyone else seeing this? The jaguar_theme_support bundle is still in the Plugins folder in the app bundle, so I'm assuming this issue is not intentional (in other words, RunRev have not intentionally dropped support for 10.2.x). This 

It seems like we've had this happen in the past, where switching to a new version of Rev caused a problem like this. What I can't remember though is if there ended up being an easy fix for it, or if we had to revert to a previous version of Rev. I've checked permissions on the app bundle, which is usually the cause of such behavior, but everything looks fine to me. I've compared the info.plist files between the previous version of our app (built with Rev 3.0) and this version (built with 4.0) and the only differences are version information. Everything seems to be correct there. So I'm worried it's an engine problem.

Can anyone shed some light on this? Any ideas as to what I could try to make it work? We're in a bit of a pickle if we can't get this to work.

Thanks,
Chris


--
Chris Sheffield
Read Naturally, Inc.
www.readnaturally.com




More information about the use-livecode mailing list