AW: Is it Rev, is it Valentina, is it MacOS? Need help!

Tiemo Hollmann TB toolbook at kestner.de
Thu Jul 22 02:34:56 CDT 2010


Hi all,

Ruslan and Ivan from the Valentina List also tested and confirmed the bug,
but also can't explain what is going on.
Here is my last dialog from the Valentina list.
Perhaps anybody can see any relation to any other experience?

>From Valentina list: ">" are the postings from Ruslan:
Hi Ruslan,

> 
> > but it displays all Umlaute with wrong symbols
> 
> Font problem ?

I have never changed anything with the fonts in my program, still using
standard Tahoma, no special settings on the fields

> 
> * Ivan have test REV 3.5 and REV 4.0  -- same problem for him So it not 
> looks like REV have changed something
> 
> 
> * Ivan say that on WIN and MAC it not works for him. Not 3.5 not 4.0 
> You say that WIN works for you ... Strange ...

Yes definatly it works on Win with both versions (I am using IOEncoding
"Latin1") and not on Mac (using IOEncoding "Macintosh") with any version

> 
> This means for me ... That problem is
> 
> A) in REV itself

But above Ivan confirms, that it is in 3.5 and 4.0, so it can't be Rev. I am
puzzeled

> 
> B) in Fonts of Window / controls that get this string ...

Nothing changed there

I also tried Peter Maleckis advice to use: set the unicodeText of fld
"data_from_valentina" to uniencode(cursor_variable,UTF8) but the result is
the same, it shows only the same specials chars for Umlaute.

> 
> 
> I did not ask Ivan, if he have try this test
> 
> REV CODE:
> 
>  put "Some strings with accents" into v1
>    save v1 to field of cursor
> 
>   read field of cursor into v2
> 
> 
> v1 and v2 must be the same byte to byte ...

I tested it and it the same

So what do we learn about all this?
My code didn't changed, Rev didn't changed, Valentina didn't changed... I
even restored OSX from January (where it still worked) What is going on
here?

Thanks for any care
Tiemo




More information about the use-livecode mailing list