Is it Rev, is it Valentina, is it MacOS? Need help!

Tiemo Hollmann TB toolbook at kestner.de
Fri Jul 16 04:30:36 CDT 2010


Hello,

tracking down a mysterious error since days and days I am stuck now. It is
such a strange error that probably nobody has ever had this particular
problem, but perhaps somebody can find any relation to any other experience
and bring me up on the road again.

My standard development environment is Windows (was XP and now Win7), but I
also have the environment on Mac. My standard procedure was to build also
the Mac standalone on Win and just add the Valentina drivers on Mac after
having copied the standalone to Mac (which has worked fine).

The Error appears in the standalone only on Mac, on Win it still runs fine

I have a dictionary rev app with a Valentina DB, which run fine over a year.
After one of the last Updates, which wasn’t related to any Valentina
handler, I got two errors on startup, a function in a substack threw an
error and my very first Valentina_init statement failed. I (actually Mark
S.!) could get to run the substack again after having removed a german
Umlaut from a function. But the fail of Valentiny_Init remained. At the very
first Valentina Call  (VDatabase_IsOpen) it throws me off without any result
or syserror. When trapping the function with try-catch I get “error in
function handler – no hint”.

 

So I decided to build the standalone on the Mac and the error seemed to be
gone, I build the next release and delivered to my customers until I got
weird support calls from my Mac customers that they can not select any more
any words with german Umlaute äüöß from the DB. Everything else works fine
with the new release. The Valentina DB can be opened and seems to work
almost normally. Btw. Displaying datas with german Umlaute works OK (the
IOEncoding of the Valentina DB is “Macintosh”). It’s just the selecting. But
searching (SELECT) for words with Umlaute is an essential “feature” in a
german dictionary!

 

I tried to reproduce the error on my machine and yes, I can’t select any
Umlaute any more. That means with selecting any words containing an Umlaut,
the result list remains just empty.

What I tested:

-          Building the Mac standalone on Win: it fails on the very first
Valentina statement

-          Building the Mac standalone on Mac: no fatal fail, but selecting
Umlaute returns empty

-          Taking an old DB from a functioning release or a new DB: same
problem

-          Reinstalling Valentina: same problem

-          Testing with Rev 3.5 and 4.0: same problem

-          The old standalone builds: still run fine on the same machine

-          Running an old rev file in development environment: same problem

-          Testing another test app with Valentina shows the same result, so
the problem is not in the code of my file

-          I copied an old standalone bundle on the Mac, which still runs
fine. After that I copied the newly created app into this old bundle – and
it works! STRANGE!

 

What does this tell us? I don’t know enough of the depths of the Mac. It
looks as if the problem is with the integration of the Valentina drivers
(because it runs with the old package), but I compared every single file in
the packages and the newly created package with the Valentina drivers looks
exactly the same as the old packages. And even if it is a case of the
Valentina drivers, who could this affect just the handling of the Umlaute?

It almost appears to me that there came any conflict between MacOS and
Valentina and/or Rev with any MacOS Update.

Has anybody ever encountered such a case (probably not with Valentina, but
perhaps something similar)?

I posted already to the Valentina List, but this problem seems to be too
strange to get help.

 

Any idea or hint what I could do or test is highly appreciated

Thanks Tiemo

 

 




More information about the use-livecode mailing list