Problem Updating mySQL Record

Sarah Reichelt sarah.reichelt at gmail.com
Tue Feb 9 19:32:20 CST 2010


On Wed, Feb 10, 2010 at 10:46 AM, Andrew Kluthe <andrew at rjdfarm.com> wrote:
>
> While not very pretty yet, I am trying to cobble together an update handler
> for updating a "Payment" record.
>
> It keeps trying to put NULL into "LeasePaymentDollars" field in my DB. This
> is weird because I check the SQL query its trying to execute and everything
> is as it should be.
>
> I have a sneaking suspicion that it has something to do with the
> tLeasePaymentDollars variables Data type.
>
> Here is the query that the handler is producing. Note: I first tried putting
> single quotes around the value and it did not work, so I tried it without
> and get the same result.
>
> UPDATE tleasepayments SET LeasePaymentDollars=1337.0000 AND
> CropSharePercent='N/A' AND Notes='None' WHERE LeaseID='1075'


There doesn't appear to be any problem with this SQL.
What is the data type for LeasePaymentDollars in the database table?
When you execute the query, do you get an error report?

Cheers,
Sarah



More information about the use-livecode mailing list