Dictionary has stopped working

Peter Haworth pete at mollysrevenge.com
Fri Dec 10 16:45:43 CST 2010


I did have some weird problems associated with menu bars a few months  
ago which were never resolved.  I defined a set of menus for my main  
stack and set the option for them to be displayed in the Mac menu bar  
not the stack window.  After that, every time I ran my application my  
main stack window increased in height by the number of pixels that  
would be used for the menu bar if it had been in the stack window.   
This was a cumulative effect so the main stack window just kept  
getting bigger and bigger.

Was never able to solve why that happened even with help from folks in  
this list so I ended up setting the correct height of the stack window  
by script.

Pete Haworth

On Dec 10, 2010, at 2:37 PM, Joe Lewis Wilkins wrote:

> Thanks Peter. What is driving me crazy, though, is the changing of  
> the stack height as I go from card to card. No rhyme or reason for  
> that and JUST started happening. I've been working on this project  
> for over two months now. At one point I did have the resizable check  
> box set, but I've changed that now. (sigh!) I have started switching  
> back and forth with the menus, making some in the Mac Menu bar and  
> some on the cards. Maybe this is confusing LC and may be the source  
> of my problem.
>
> Joe Wilkins
>
> On Dec 10, 2010, at 2:26 PM, Peter Haworth wrote:
>
>> I have had problems with the Dictionary turning up blank but only  
>> in a pretty specific circumstance.  It usually happens when I am in  
>> browse mode and I have debug break points set.  If I stop  
>> exxecution of the code by clicking on the blue square in the debug  
>> toolbar, then go to the dictionary and try to select/click on an  
>> entry, the whole dictionary is blank.  But if I switch back to edit  
>> mode,, the dictionary entries all come back again.  Doesn;t sound  
>> like it matches your circumstances though.
>>
>> Pete Haworth
>>
>> On Dec 10, 2010, at 2:01 PM, Joe Lewis Wilkins wrote:
>>
>>> Has anyone ever had this happen to them? Everything is blank. I  
>>> restarted LC and, finally, my MacPro, running Snow Leopard. The  
>>> height of my substacks has been changing on me. Just started  
>>> happening. Any chance I need to reinstall LC?
>>>
>>> Joe Lewis Wilkins
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>




More information about the use-livecode mailing list