revOpenDatabase on Linux - works in IDE, broken in standalone - how do I fix?

Riccardo tekne at gruppoparentesi.it
Fri Jan 9 15:38:37 CST 2009


You can try not use the automatic inclusion of the library in the  
standalone settings. I have solved in this way the same problem with  
mysql.

Riccardo
Inviato da iPhone

Il giorno 09/gen/09, alle ore 17:22, Ben Rubinstein  
<benr_mc at cogapp.com> ha scritto:

> Accessing PostgreSQL database on Linux.  Works in IDE; using  
> standalone,
> throws error in revOpenDatabase. (219: Function: error in function  
> handler).
>
> Works in both 2.9 and 3.0 in IDE; fails in standalone built from  
> either.
>
> Looking at the Externals folder of the standalone, in both I get:
>
>    revxml.so
>    [database_drivers]
>        dbmysql.so
>        dbodbc.so
>        dbpostgresql.so
>
> Whereas looking at the actual Rev installation (ie "2.9.0-gm-1" or
> "3.0.0-gm-3") the Externals folder looks like this:
>
>    Externals.txt
>    revdb.so
>    revxml.so
>    revzip.so
>    [database_drivers]
>        dbmysql.so
>        dbodbc.so
>        dbpostgresql.so
>
> So I copied the extra .so files, and the Externals.txt file, over to  
> the
> standalone installation - that didn't fix it.
>
> Please help!
>
> TIA,
>
> - Ben
>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution



More information about the use-livecode mailing list