ListMagic Printing

Jerry Daniels jerry.daniels at me.com
Tue Feb 17 12:43:10 CST 2009


Bob, Jim...

GLX2 v2.4b33 is now available. Problem with execution errors within  
locked stacks fixed. General handling of execution errors much improved.

Best,

Jerry Daniels

Daniels & Mara, Inc.
Makers of GLX2
http://www.glx2.com

On Feb 15, 2009, at 3:10 PM, Jim Bufalini wrote:

> Hi Bob,
>
> Thank you for taking the time be more explanative. As a result, I  
> was able
> to duplicate the problem. It is due to a combination of factors:
>
> 1. Running LMPrint from the message box.
> 2. Running GLX2.
> 3. A bug in one ListMagic's print formatting handlers.
>
> The spinning beach ball is coming from GLX2 trying to report an  
> error coming
> from a locked stack (I'll let Jerry know). Disabling the revGLX2  
> Code plugin
> results in a Rev error that says it can't tell you exactly what it is
> because the stack is locked. But there is no hang. Lastly, the cause  
> of the
> error in the first place being the bug in one of ListMagic's print
> formatting handlers.
>
> I'll release a update within the next couple of days that will  
> correct this
> as well as some other minor issues reported.
>
> Once again, thanks for taking the time to report the problem. We'll  
> get
> corrected in short order.
>
> Jim Bufalini
>
>> -----Original Message-----
>> From: use-revolution-bounces at lists.runrev.com [mailto:use-revolution-
>> bounces at lists.runrev.com] On Behalf Of Robert Sneidar
>> Sent: Saturday, February 14, 2009 11:15 AM
>> To: How to use Revolution
>> Subject: Re: ListMagic Printing
>>
>> Hi Jim. Sorry didn't mean to come off that way.
>>
>> I used the lmprint command from the message box. I got the page setup
>> and print dialogs ok. I chose Format For and chose a local printer on
>> the network. When I got to the print dialog I clicked the Preview
>> button. It was at that point I got the Printing dialog and the
>> spinning beach ball. That went on for over a minute at which point I
>> treid to cancel. It then changed to cancelling printing but never
>> actually did. I didn't try again. I had to quit Revolution which i  
>> did
>> via the keyboard. Every attempt to open a card containing a listmagic
>> object after that threw errors so I had do delete the listmagic
>> objects and scriptingi can try again and see if I get the same
>> problem. I will say that I had recently used the VAB in GLX2 which I
>> have had problems with so let me reproduce the error and get back to
>> you.
>>
>> Bob Sneidar
>> IT Manager
>> Calvary Chapel CM
>> Sent from iPhone
>>
>> On Feb 13, 2009, at 20:52, Jim Bufalini <jim at visitrieve.com> wrote:
>>
>>> Hi Bob,
>>>
>>>> Has anyone tried to print from Listmagic yet? I tried to use the
>>>> Preview option in the OS X print dialog and it basically locked up
>>>> with a dialog that said it was printing but never really did.
>>>> Cancelling did not cancel. I had to quit Revolution to get out of
>> the
>>>> loop. When I did that, clicking gave me the "don't do that!" system
>>>> beep, but oddly I could use the keyboard and the Revolution Menu so
>> I
>>>> was able to quit gracefully.
>>>>
>>>> I only mention this to warn people so they do not get hung up with
>>>> this or produce a commercial app and then have their users run into
>>>> this.
>>>
>>> Well, that's a stern warning. ;-)
>>>
>>> Can you tell me what happens if from the Action tab of ListMagic you
>>> click
>>> on the Actions menu on the upper right and select Print. You should
>>> get a
>>> Page Setup screen. Select Portrait and OK. You should get a nicely
>>> formatted
>>> Test list of the sample data.
>>>
>>> Did you use the LMPrint command described in the Syntax tab of
>>> ListMagic to
>>> do your print? The LMExport also works nicely from this menu.
>>> Basically you
>>> need to use the handlers provided with ListMagic in your app.
>>>
>>> Jim Bufalini
>>>



More information about the use-livecode mailing list