Launch document problems

Bernard Devlin bdrunrev at gmail.com
Mon Feb 2 18:14:57 CST 2009


Hi Scott,

I've got a few suggestions (I've experienced a few peculiarities with
'launch document' at various times).  The problem with my suggestions is
that they are not as simply cross-platform as the basic 'launch' command.
If you are only dealing with Windows, then this should not be a problem.

1) There is another version of that command: 'launch [documentPath with]
applicationPath' (see dictionary).  It could be that OpenOffice is not being
launched with files of .csv.

2) There is also the 'shell' command in Revolution, and you can build a
command line string then use that to launch a program.  OpenOffice can be
launched from the command line and told to start with a particular
sub-application (e.g. the spreadsheet) by calling it from the command line.
I've only skimmed OOo, but if you google "openoffice.org" "command line" the
first few hits should point you to the kinds of command options available.
I didn't see that one could pass along a document path when starting from
the command line, but it would be unusual for that to NOT be the case.

Hope one of those suggesions gets you a little further...

Bernard

On Sat, Jan 31, 2009 at 12:37 AM, Scott Pepperdine <spepper at byu.net> wrote:

> J. Landman Gay wrote:
>
>> Scott Pepperdine wrote:
>>
>>> Hi all,
>>>
>>> I'm trying to use 'launch document' to open a .csv file in a spreadsheet.
>>>  I keep getting the result of "can't open file", which tells me the file
>>> could not be found, or is not accessible.
>>>
>> Since you've tried checking for existence, the file is probably found.
>> More likely is that it is inaccessible to Rev, which could be a permissions
>> issue. Have you tried moving the file to a folder that is accessible to the
>> current user, like the desktop?
>>
>>  Hi Jacque,
>
> Thanks for the response.  I'm signed on as Administrator on this box, so I
> didn't think permissions would be the problem, and it was not.  When I
> changed the associated program for .csv files from OpenOffice to Lotus 123
> it worked just great.  When I use "launch document" to open .rtf and .doc
> and .xls files with OpenOffice it works just fine also.  It is only when I
> try to open .csv files with OpenOffice that it does not work.  Either a
> problem with OpenOffice or the association I have set up with .csv files.
>
> In any case the problem was not with Rev, and thanks again for the
> response.
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>



More information about the use-livecode mailing list