Strange cursor behavior on several fields

George C Brackett gbrackett at luceatlux.com
Sun Feb 1 11:27:33 EST 2009


One tiny thought: tPrefix isn't initialized unless it's a script local  
variable.

George

On Feb 1, 2009, at 8:51 AM, William de Smet wrote:

Hi there all,
I got some 'strange behavior' of the cursor after  'on mouseup':
the cursor keeps jumping from field to field but not all fields.
I tried to cope with it by setting the focus on one field but no result
either.
I don't see why this happens. Anyone knows?

*on* mouseUp

   *if* the icon of me = 1217

   *then* *set* the icon of me to 1223

   *else* *set* the icon of me to 1217

   *repeat* with x = 1 to 50

      *put* tPrefix & x into tVarName

      *if* the lockText of fld tVarName = true

      *then* *set* the lockText of fld tVarName to false

       *then* *set* the listBehavior of fld tVarName to false

   *then* *set* the showborder of fld tVarName to true

   *then* *set* the autohilite of fld tVarName to true

   *--focus on fld "b1"*

*else*

      *set* the lockText of fld tVarName to true

      *set* the showborder of fld tVarName to false

      *set* the listBehavior of fld tVarName to true

      *set* the autohilite of fld tVarName to false

      *end* *if*

   *end* *repeat*

*end* mouseUp


Greetings,


William
_______________________________________________
use-revolution mailing list
use-revolution at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your  
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution





More information about the Use-livecode mailing list