Blank Page printed with RevPrintField command

zryip theSlug zryip.theslug at gmail.com
Sat Dec 19 17:40:16 EST 2009


Hi Brent,

The blank result means that RR did detected any problem.

So you need to isolate the problem by testing different possibility.
If necessary send the results of your tests in a dialog box and then
rebuild your application for windows.

- It is possible that the field is not found: test the existence of
the field "Results"
- It is possible that your printing is done in white. Test the font
color printing. Fix the color to black before printing
- This could be a font not existing in windows. Verify that the font
used in your field exists in your Windows configuration.
- Check the font size when printing under windows. May be your font is
to small or to big.
- Try to print with another printer or with a pdf driver (like pdf
creator). Maybe it's a problem with the printer or with its driver.

I am not yet familiar with the RR impressions. Just a few ideas;)


-Zryip TheSlug- wish you the best ! 8)

2009/12/17 Brent Summerton <___BG___ at virginbroadband.com.au>:
> Using a Mac 10.6.2  RevPrintField function prints page within application being design all okay - but not when exported as a standalone application and used on a PC running Vista.  It is only printing a BLANK page then.
>
> My Script is:
> On Mouseup
> RevShowPrintDialog true, false
> RevPrintField the long id of field "Results"
> End Mouseup
>
> I am using the $500 Enterprise 4.0.0 Edition.  When instructed to placed the "answer the result" after the printing commands - It returns a blank dialogue box which does little to help make the cause of error clear.  By the way....  I have checked under General that the print feature is selected to export with standalone windows application.
>
> Is there any format to the field that I should be aware of? Locked/ Unlocked/ Disabled, Font? Is this a glitch when designing on Mac, exporting to Windows standalone?



More information about the Use-livecode mailing list