virtual desktops in linux, very weird

Bernard Devlin bdrunrev at gmail.com
Sun Oct 5 13:49:00 EDT 2008


To be honest Peter, I do have sympathy for Rev in this regard.  The number
of desktop/WM programs is quite varied in Linux compared with say Windows or
OS X.  I know that there are a small percentage of Windows users who might
run weird desktops/application launchers instead of the Explorer interface,
and maybe the same thing can be done for OS X.  But they are a tiny
percentage, and it is reasonable that things might break with these
exceptions.  Yet much of the terrain of Linux is varied (as you have pointed
out a few days ago), so there are just a lot more exceptions.

I don't think it is reasonable for me to expect Runrev to test out every
permutation on Linux.  For example, today I entered a bug report because the
File Open window works correctly in Debian/Ubuntu, but doesn't work
correctly in Fedora 8.  I marked it as 'minor', because there is a
workaround (don't use that part of File Open, or don't use Fedora 8).
That's fine for us developers working within the IDE, not so fine for end
users.

I'm assuming that Runrev's developers have used a standard API call to show
the open file dialog.  And probably they tested it worked in Ubuntu or
Debian.  I can't really blame them if that same API call doesn't work in
Fedora (even if the API seems to work for every other app in Fedora).  Also,
I note in http://quality.runrev.com/qacenter/show_bug.cgi?id=5789 that Rev
seems to exhibit different behaviour in Ubuntu than in Debian or Fedora,
with regard to the initial and subsequent position of the menubar on
startup.  I don't know again if this is due to a Linux API being
inconsistent, or if there is some conditional coding inside Rev to make it
behave in different ways depending on the environment it is running within.

It would be nice if multiple virtual desktops worked with the IDE.  I know
it works for the windows of other Linux apps, and I've heard Rev works with
OS X's virtual desktops.  But I'm focussing my energy on the fact that Rev
3.0 hangs, crashes and leaks memory.  I've given up for lost the hope of
having it work on virtual desktops.  I'm going to use an external editor
with stsmlxEditor, and I have Bjoernke's docu working as a standalone so I
don't have to position the dictionary.

Bernard

On Sun, Oct 5, 2008 at 6:04 PM, Peter Alcibiades <
palcibiades-first at yahoo.co.uk> wrote:

>
> OK, finally tested this on exactly the same machine, but with WindowMaker
> and
> Fluxbox.  In both cases it works fine.  You can put either the dictionary,
> the stack you're working on, the editor, the property inspector all on
> different windows.  You can then drag and create a button lets say, do
> 'edit
> script' and when you flip back to the workspace where the script editor is,
> there it is waiting to be edited.  If memory is correct, this was also the
> situation with 2.9.  Maybe this was why I at first thought it was working,
> must have been using Fluxbox.
>
> Yet on Gnome it doesn't work at all.  You can move windows to other
> desktops, but as soon as you go to the other desktop, back they flash to
> the
> one with the Rev menubar on it.  It will probably not work on KDE as it did
> not in 2.9 either.
>
> How can this be, that it works in WM and Fluxbox, but not in Gnome, when
> nothing else has changed? This is apart from the WM being used, exactly the
> same config in all cases.  I am not restarting, just signing off and then
> signing on again.
> --
> View this message in context:
> http://www.nabble.com/virtual-desktops-in-linux%2C-very-weird-tp19825390p19825390.html
> Sent from the Revolution - User mailing list archive at Nabble.com.
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>



More information about the Use-livecode mailing list