Weird Send in Time Problem???

Eric Chatonet eric.chatonet at sosmartsoftware.com
Thu Oct 2 07:58:23 EDT 2008


Bonjour Dave,

I just bet you have several 'Timer' messages pending at the same time.
To be sure to have one only, use:
if "Timer" is not in the pendingMessages then send "Timer" to me in 1  
second
Another thing:
Prefer to write your data in your field only once:
put the seconds & cr & the openStacks & cr & cr after field 1
Multiple screen refresh is always time consuming :-)

Le 2 oct. 08 à 13:32, Dave a écrit :

> I have a test stack with one button and one field, the Button  
> Script contains:
>
> on TImer
> put the seconds & cr after field 1
> put the openStacks & cr & cr after field 1
> set the scroll of field 1 to 9999999
>
> send "Timer" to me in 1 second
> end Timer
>
>
> on mouseUp
> put empty into field 1
>
>  send "Timer" to me in 2 seconds
> end mouseUp
>
> When I look at the result in field 1, I see
>
> 1222946339
> <<Stack List>>>
>
> 1222946339
> <<Stack List>>>
>
> 1222946339
> <<Stack List>>>
>
> 1222946340
> <<Stack List>>>
>
>
> How can the seconds property be the same 3 times in a row, when  
> there is a one second interval between message Sends???? Other  
> stacks are doing stuff, so I can see that there might be a >1  
> second interval, but not <=!
>
> All the Best
> Dave

Best regards from Paris,
Eric Chatonet.
----------------------------------------------------------------
Plugins and tutorials for Revolution: http://www.sosmartsoftware.com/
Email: eric.chatonet at sosmartsoftware.com/
----------------------------------------------------------------





More information about the Use-livecode mailing list