shortcut keys rarely working

Jim Ault JimAultWins at yahoo.com
Fri Feb 15 11:50:39 EST 2008


I have posted a workaround for Mac OSX that I use, sometimes frequently, but
most of the last 6 months, rarely.  There is a program called Menu Master
that quickly allows you to assign an alternate key combo.  I use cntrl-C and
cntrl-V.  Normally Rev will like the command-C and -V.  When it does not, I
just use the cntrl key and it works fine.  Don't ask why.  I don't know.

Copy seems to work, but the paste is problematic, solved by the cntrl key
substitution.  Of course, relaunching Rev fixes the things too.

Jim Ault
Las Vegas


On 2/15/08 8:39 AM, "Trevor DeVore" <lists at mangomultimedia.com> wrote:

> On Feb 15, 2008, at 11:19 AM, Jerry Daniels wrote:
>> Trevor has tracked down a very bothersome engine bug that seems to
>> isolate the problem: FOCUS. Once a Rev application (the IDE is an
>> application, btw) has a bunch of nested groups, the engine has to be
>> coerced into knowing what the focused object (field) really is. This
>> is where the keystrokes "go." And sometimes even coercion does not
>> work. Based on Trevor's detective work, I'm starting to believe this
>> is an engine bug--which has been reported and which is being worked
>> on presently by the lads and lasses in Scotland.
>> 
>> Perhaps Mr. T or others in the know would care to comment.
> 
> I don't have any further details on whether or not the issue is fixed
> yet for the next 2.9 build.
> 
> I am pretty sure that non-functioning shortcut keys are related to a
> confused engine when it comes to focusedObject and selectedField. I've
> been able to recreate the issue and have filed bug reports. Rev is
> aware of the issue and hopefully all of these shortcut key woes will
> go away with 2.9.
> 
> Regards,





More information about the Use-livecode mailing list