Is this mad?
R.Beynon at liverpool.ac.uk
Thu Apr 17 08:38:49 EDT 2008
Sometimes when writing code, I write things like
Repeat for each line protein in allProteins
Repeat for each char aminoAcid in protein
I'd really like this to look like this, defining a new function 'synonym'
make protein a synonym of line
make aminoAcid a synonym of char
Repeat for each protein in allProteins
Repeat for each aminoAcid in protein
Does the extensibility/flexibility make code easier or harder to read/use?
Prof R J Beynon
Proteomics and Functional Genomics Group
Faculty of Veterinary Science
University of Liverpool
Crown Street, Liverpool L69 7ZJ
Phone: +44 151 794 4312
Fax: +44 151 794 4243
Email: r.beynon at liv.ac.uk
This email was sent on 4/17/08 at 1:39 PM by Rob Beynon.
More information about the Use-livecode