OS X - Parental Controls: can't start my runrev runtime

Richard Gaskin ambassador at fourthworld.com
Thu Oct 18 11:43:41 CDT 2007


Luis wrote:

 >>> On 17 Oct 2007, at 22:52, Richard Gaskin wrote:
 >>>> So I then modified the plist within that app's bundle, and a key
 >>>> and string as you noted, and I get the same prompt.
 >>> Remember that the Finder doesn't look into the plist file
 >>> automatically when you change the file. :(
 >>> I zip the app, delete the original and unzip it, this forces the
 >>> Finder to look again.
 >>
 >> After doing this I still got the "...does not work with the
 >> limitations you have selected" error when I tried to add the app to
 >> the account permissions in the Accounts control panel.
 >>
 >> But interestingly, I find that when I log into that account I can
 >> still run that app in that limited account.
 >>
 >> Ah, the mysteries of Apple's security mechanisms....
 >
 > Have you tried doing a 'Repair Permissions' (don't do the 'Verify
 > Permissions') in Disk Utility?

I had done so yesterday before testing, but on a lark I just ran it 
again and now I can add my app.

Weird UI problem there, though:  it doesn't show up under "Applications" 
in the list there, even though that's the folder it's in.  I opened the 
tab for "Other", then did the "Locate...", and then it didn't show up 
under "Others" but was listed among the "Applications", unchecked, 
however.  So I just checked it and it was all good from there.

Thanks for the assist.

-- 
  Richard Gaskin
  Managing Editor, revJournal
  _______________________________________________________
  Rev tips, tutorials and more: http://www.revJournal.com



More information about the use-livecode mailing list