Deleting an object in a group DELETES THE WHOLE GROUP!

Richard Gaskin ambassador at fourthworld.com
Wed Oct 3 15:44:58 EDT 2007


Len Morgan wrote:
> Today I was trying to remove a field from one of the groups.  I selected 
> the group, picked "Edit Group", then selected the control I wanted to 
> delete.  As soon as I press delete, then entire group is deleted (and 
> Undo won't bring it back - in fact, Undo has NEVER worked in any context 
> I've ever tried!).  It appears that all of the other groups that were 
> "under" the one I was editing have also been deleted.
> 
> I say "I think" that happens because the Application Browser refuses to 
> show this one stack (although it shows all the others) so I can't see if 
> those groups are still there.  If I close the IDE and then restart and 
> reload the application, all of the groups have disappeared.
> 
> Any ideas what's going on?

If indeed you selected the field rather than the group, chances are the 
group is still there.  If the lockLoc property of the group is false, 
and empty group will resize to fit its contents when its contents 
change.  For an empty group, the means the group rect would be the sum 
of its borders.

So you might try clicking in the area just below the top-left of where 
the group was last seen to see if it's there.

But more interesting to me is that this stack isn't showing in Rev's App 
Browser.  What is the stack named?  If the first three letters of the 
stack's name are "rev" you might need to turn on the preference option 
which allows Rev stacks to be displayed in IDE components.

-- 
  Richard Gaskin
  Managing Editor, revJournal
  _______________________________________________________
  Rev tips, tutorials and more: http://www.revJournal.com



More information about the Use-livecode mailing list