Problem when filling first line of a field with a text variable

André.Bisseret Andre.Bisseret at inria.fr
Tue Jul 10 08:05:41 EDT 2007


Thanks to Malte, Éric and Jim for their answers.

To Malte :
> does
>
> put thisText into line 1 of fld “thisField” of stack "stackTwo"
>
> work instead of going there?

No, this works not better.

To Éric and Jim :
Sorry, my message was not enough precise : In my script, actually, I  
have the correct syntax :  go to stack "stackTwo"
More precisely, the name "stackTwo" is in a variable (say vstackTwo),  
so that I write : go to stack vStackTwo

and I know that it goes there ; the fleld of stack "stackTwo" is  
actually filled, but infortunately without line 1 of the text I put  
in the variable.

My feeling is that I have made this a lot of times without any  
problem, so I am completely lost facing such an issue.
I am sure I am on the right stack when I ask to put the variable in  
the field
I am sure the complete text is in the variable theText as I test it  
just before with "put thisText" that returns the complete text in the  
message box

But anyway, the field is filled by the text without its first line !

If I do exactly the same thing (in the same stack, the same field  
etc.) via the message box, it works normally !!!!!

I am loosing hope (first time I encounter such an enigma)

Best regards from Grenoble
André

Le 10 juil. 07 à 12:15, Eric Chatonet a écrit :

> Bonjour André,
>
> I tried the following:
>
> on mouseUp
>   local ThisText
>   -----
>   put "a,b,c" into ThisText
>   replace comma with cr in ThisText
Well, the lineDel is already cr in the text I am putting in my  
variable thisText
>   go to stack "StackTwo"
>   put ThisText into line 1 of fld "ThisField"
> end mouseUp
>
> And it worked as expected.
> The only thing I notice in your script is that you write:
> go to StackTwo
> And that's not correct syntax :-)
As for that, my post was not correct, not my script ; I apologise
>
> Le 10 juil. 07 à 11:56, André.Bisseret a écrit :
>
>> Hi,
>> After hours of unsuccessfull trials to understand where I am  
>> making a mistake I make up my mind to ask for help
>>
>> If I summarize my script :
>> I have two stacks : stackOne and stackTwo
>> In the script of a button in stackOne
>>
>> I put a text of several lines in a variable, say, thisText
>>
>> then the script continues with :
>>
>> go to stackTwo --where I have a field “thisField”
>> put thisText -- to confirm the text is in the variable
>> put thisText into line 1 of fld “thisField”
>>
>> Invariably, I get the full text thisText in the message box – as  
>> expected
>> but, in fld “thisField” , unexpectedly, the first line of thisText  
>> is not written in the fld thisField ; the first line of thisField  
>> is empty,
>> only the following lines (2, 3 etc.) are visible
>>
>> After a lot of hypotheses and checkings I am out of ideas
>>
>> Please, any assumption on what am I missing ?
>> Thanks a lot in advance
>>
>> Best regards from Grenoble
>> André
>
> Best regards from Paris,
> Eric Chatonet.
> ----------------------------------------------------------------
> Plugins and tutorials for Revolution: http://www.sosmartsoftware.com/
> Email: eric.chatonet at sosmartsoftware.com/
> ----------------------------------------------------------------
>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>
>





More information about the Use-livecode mailing list