OS X cgi error

Richard Miller wow at together.net
Thu Dec 6 19:27:33 CST 2007


Finally got it. My ftp client was altering the files as they were  
being sent to the server. Had to switch to binary transfer from  
ASCII. Along with all the other suggestions, it's now working. Thanks  
to all of you for your help.

Richard


On Dec 6, 2007, at 1:48 PM, J. Landman Gay wrote:

> Richard Miller wrote:
>> Paolo,
>> I am positive I am using the correct engine. I downloaded it again  
>> to be sure.
>> What other possibilities exist as the source of this problem?
>> Again:
>> - Nothing in the cgi-bin except for the Darwin engine and the  
>> hello.cgi  script.
>> - The hello.cgi script is saved as a text file.
>> - All permissions in the cgi-bin are set to 755.
>> - The owner of the cgi-executables folder is my login id.
>> - The group is "www"
>
> I have never seen the "license" error you mentioned. I just  
> downloaded the same engine and tried it on my intel iMac. All I did  
> was drag the engine file to the CGI-Executables folder. From  
> Firefox, I opened a URL to the "echo.mt" test script and I got the  
> "premature end of script header" message, then remembered I hadn't  
> set permissions, so went to Terminal to change the engine  
> permissions to 755. After that, it worked fine. Did you use  
> Terminal to set permissions? The Get Info box won't always work for  
> that. Also, the line endings in your text file should be unix  
> endings (LF).
>
> -- 
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the use-livecode mailing list