External won't load on some machines

Andre Garzia soapdog at mac.com
Mon Oct 30 09:14:36 EST 2006


Jacque,

I experienced similar problem here, I solved it by explicitly binding  
the external during the startup handler in the standalone, then it  
resumed working. Try setting the external prop in the startup  
handler, this will not solve the problem of the external not loading  
in the IDE but it might solve for standalones.

Andre
On Oct 30, 2006, at 4:49 AM, J. Landman Gay wrote:

> This is too weird. I have an app that uses a custom external. I've  
> been working with it for months, up until recently, when I stopped  
> testing it.
>
> Today I tried it again and it won't load at all, either in  
> Revolution or in the standalone. I get "error in function handler"  
> at the place where the external is called. The external is located  
> in the correct Externals folder (Rev) and in the correct place in  
> the application bundle in the standalone. I also tested in MC,  
> where the external is located in the correct place inside the  
> engine's folder. The same copies of this external have been sitting  
> in these folders for over six months and always worked in the past.  
> All of these fail now. I have tried engines 2.7.4, 2.7.3, and 2.7.2  
> with the same results. I know that at least 2.7.2 and 2.7.3 were  
> working fine previously. I used the same test stack that has always  
> worked before.
>
> The standalone is shipping currently and we have had three people  
> report the same problem recently. However, most people using the  
> exact same download are not having a problem and the external loads  
> fine. I sent a new build to the client today, and it works fine for  
> him too -- but when I run it, it fails.
>
> What would make an external fail to load on some machines and not  
> others?
>
> -- 
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the Use-livecode mailing list