Developer Annoyance #1
Arthur Urban
aturban at qwest.net
Fri Mar 17 00:43:49 EST 2006
I think a new syntax needs to be made available for calling functions
outside the message hierarchy. The existing mechanism does not lend
itself to high readability or maintainability. Consider the following,
if you will:
put 1 into varA
put 2 into varB
put value( merge("calc([[varA]],[[varB]]))", btn "source" ) into
localResult
further, if I need to protect the integrity of the variable passed it
begins to look like this:
put "1,2,3" into varA
put 4 into varB
put value( merge("calc([[quote&varA"e]],[[varB]]))", btn "source"
) into localResult
I'm not sure that this is the right direction for any language to be
headed. Please explain why we can't have the following syntax:
put calc(varA,varB) of btn "source" into localResult
More information about the use-livecode
mailing list