2.7 "corrupts" 2.6.1 stack - Help!

Peter T. Evensen pevensen at siboneylg.com
Tue Feb 21 17:44:28 CST 2006


The 2.7 format is different, so 2.6 won't read a stack created in 
2.7.   Chipp created a plugin (for 2.7) to go back to the previous version:

>As many of you have read, the file formats are no longer backwards 
>compatible with the new 2.7. Thoughtfully, RunRev provided many of us beta 
>testers with a way to force a stack to revert back to an old file format 
>using an undocumented and unsupported global property.
>
>This of course is fraught with potential problems. If you use a newly 
>introduced token in a script, chances are your new stacks would break when 
>opening in a previous version even when using this plugin.
>
>But, if you're like me, and you have to go 'back and forth' (for instance 
>our plugins must work in both environments), you really need to be able to 
>do this. So, I wrote this plugin and thought I'd share it with the community.
>
>I'm not sure the reason why RR won't publish the global property to make 
>this possible. But, in the meantime, I've written a plugin, which you can 
>place in your 2.7 plugins folder, which will do this. I've password 
>protected the stack so that Rev's secret global prop is still secret, and 
>of course I provide no warranties it will work all the time, but it can be 
>a lifesaver if you're toggling back and forth between apps.
>
>I also recommend using our altArchive plugin as well to maintain 
>serialilze archived versions of your stack each time you save.
>
>To get the StackFormat plugin, just type into your 2.7 message box and hit 
>return the following:
>
>go URL "http://www.gadgetplugins.com/altplugins/StackFormat.rev"



At 05:39 PM 2/21/2006, you wrote:
>So here I was, playing with my newly downloaded copy of 2.7.
>
>Stupidly, I used it to open the latest version of a very complex project 
>on which I have been working on a long time, and for which I haven't made 
>a recent backup.
>
>The mainstack opens up with only a few visual anomalies, but after closing 
>it, it refuses to open in 2.6.1, telling me that the stack is corrupted 
>and to try the backup.  Nor will it run in the 2.6 Player.
>
>Interestingly (or perversely if you view it that way), the stack WILL 
>reopen in 2.7, but with the same few visual anomalies.
>
>But even a copy "saved as" will not open in 2.6.1, where I really need to 
>continue the project.
>
>Has anybody experienced this, and is there any way to get back to where I 
>can use the stack in 2.6.1?
>
>A positive solution will save me MANY hours of additional work, and would 
>really be appreciated.
>
>I'm on a Mac Powerbook G4, running 10.3.9
>
>Thanks in advance,
>Alan Gayne
>_______________________________________________
>use-revolution mailing list
>use-revolution at lists.runrev.com
>Please visit this url to subscribe, unsubscribe and manage your 
>subscription preferences:
>http://lists.runrev.com/mailman/listinfo/use-revolution

Peter T. Evensen
http://www.PetersRoadToHealth.com
314-629-5248 or 888-628-4588 




More information about the use-livecode mailing list