Please clarify incompatibility re 2.7

J. Landman Gay jacque at hyperactivesw.com
Tue Feb 14 17:32:11 EST 2006


Timothy Miller wrote:
> Hi,
> 
> Jacque's previous message regarding incompatible stack formats worries 
> me. It's probably no big deal, but, better safe than sorry.
> 
> If I have been running my stacks without problem on version 2.6.1, in 
> Macintosh OS X, and I now upgrade to 2.7, what kind of problems, if any, 
> will I have if I need to use the Mac OS X Rev version 2.6.1 again, for 
> some reason?

Stacks saved in version 2.7 will no longer open in version 2.6.1 or 
earlier. You will get an error that the stack is corrupted. They will 
still open fine in 2.7.

There is a property you can set before saving in 2.7 that will make the 
stack compatible with 2.6. However, the information has been removed 
from the What's New text file and it isn't in the dictionary. I'm not 
sure why. Possibly it is because any 2.7 features you've used in a stack 
will be lost if saved in 2.6 format and they don't want people to risk 
that loss.

> AFAIK, 2.7 isn't ready for Mac OS 9.2. I guess 2.6.1 might be the end
 > of the line for that platform.

The download page on the web site says that an OS 9 version is to be 
available soon, so it doesn't look like they are planning to discontinue it.

-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com



More information about the Use-livecode mailing list