altSQLite variable substitution (partial solution)

Jim Bufalini yoursignup at yahoo.com
Thu Dec 14 06:30:27 EST 2006


Mark,

> My altSQLite problem is now partially solved, thanks to Chris Bohnert.
> Turns out I had an early (and buggy) version of the driver. Now that
> I've got the latest installed I can save blob data without a problem.
>
> Now... has anyone been able to get blob data *out* of an altSQLite
> database? I've tried both revQueryDatabaseBLOB and revDataFromQuery
> and they both return the encrypted data verbatim without decrypting it
> on the way out. The documentation for both these functions is wrong
> (surprise, eh?), so I'm not even sure why the data is getting
> encrypted on the way in.
>

Not sure what you mean by "encrypted." I suspect you are trying to write
standard text data to a "blob" typed field. This won't work. The data you
write has to be binary going in. See my previous suggestion of using Rev
compress() before write. Then decompress() after read. If this doesn't work,
have Chris send you the driver he sent me about a month ago.

Jim





More information about the Use-livecode mailing list