Image question

Klaus Major klaus at major-k.de
Thu Dec 7 09:23:18 EST 2006


Hi Mark,

> Hi all, I am a complete ignoramus when it comes to handling images,  
> icons and so-on.
>
> I've downloaded some good freeware icons (http://www.fasticon.com/ 
> downloads.html)  for an app I'm making, and they're in the form of  
> folder icons ie. a bunch of empty folders which show their icons in  
> the finder (I'm on OS X).
>
> If I "get info" and copy the icon from the the finder  info window  
> and then paste onto my stack using "paste image", I get an  
> apparently empty image. If I use iconoghrapher to open the icon,  
> and then copy it, and "import image as control" in Rev, I get the  
> image, but it's background rectangle is white in some cases, or  
> half the image is invisible in others. This is to do with masks and  
> alpha data and stuff which I don't currently understand, I guess.
>
> Can anyone suggest the easiest way to get these icons into my stack  
> such that they display properly?

well, the trick here is to download the WINDOWS icon pack :-)
That will contain a bunch of "*.ico" files but "Preview" can open them!

The mac version contains "Adobe Photoshop Pict resource" files, as  
told by the "Info" window,
but Photoshop cannot open them!

Since there are several images in one file, open the drawer in  
"Preview" and click the
expand arrow fo the image on top of the drawer.

Select the icon you want to use by clicking/selecting it and choose  
"Save as..." from the file menu.
Choose "PNG" as fileformat and check (if not already checked) "Alpha".

NOW you can import the image into Rev without problems!
A BIT tedious, but does work :-)

Hope that helps.

> Thanks for any help,
>
> Mark

Regards

Klaus Major
klaus at major-k.de
http://www.major-k.de




More information about the Use-livecode mailing list