Clipboard madness

MisterX b.xavier at internet.lu
Thu Sep 22 12:46:27 CDT 2005


I identified the real problem with this clipboard problem...

again, doing rev's beta tester's job...

Who-ever wrote the html compatibility code in rev should be wipped like a
petach d'mes deux!

put the clipboarddata["text"] -- contains the right information

while 

put clipboarddata["html"] -- is definitely wrong and should not be
trusted...

Yet another case of the RevHTMLtranslation going wrong...
Fields, Clipboard, entity characters...

on pastekey
  imagine easy script to fix a 4 year old problem...
end pastekey

I just keep adding to HotKeyNO2 all the missing features of rev ;)

cheers
Xavier


-----Original Message-----
From: use-revolution-bounces at lists.runrev.com
[mailto:use-revolution-bounces at lists.runrev.com] On Behalf Of
xbury.cs at clearstream.com
Sent: Thursday, September 22, 2005 11:23 AM
To: How to use Revolution
Subject: Clipboard madness

Yesterday i was BATTLING against a stack who wouldn't copy paste information
from a field to ultraedit... I tried all keyboard combos, and even the menu
- just i wouldn't copy anything... maybe it's due to the environment i run
this into: it runs on a windows 2003 server which has 4 metaframes opened,
4-8 RDP windows (terminal services), Notes (biggest crap mail client you
could find in the galaxy), and FireFox (who doesn't know how to copy paste
any better...). I managed to make this work via a button: select text of fld
x, copy!

So why doesn't the menu or keycombos work?

Today, when i copy the line from any program

emcacl \\server\fs$\userprog\xxxxxxx /t /c /y /q /g "SYSTEM":F
"OAAD\xxxxxxx":C

and paste it into a field (or scripteditor) and what i get is:

emcacl \\\\$\\/t /c /y /q /g "SYSTEM":F "OAAD\":C

Tested in Rev 2.6, Metacard 2.62...

3rd bugzilla entry today... Rev should sponsor those who do their
beta-testing - but i get the feeling this is an persistent problem ;)

The big question: Is this in windows only? 

I'd like to see if any of you Mac users also have this problem before i
enlarge further the zilla list ;)

If this was a compiler problem, how many sins would it imply? ;D

cheers
Xavier


-----------------------------------------
Visit us at http://www.clearstream.com
                                                          
IMPORTANT MESSAGE

Internet communications are not secure and therefore Clearstream
International does not accept legal responsibility for the contents of this
message.

The information contained in this e-mail is confidential and may be legally
privileged. It is intended solely for the addressee. If you are not the
intended recipient, any disclosure, copying, distribution or any action
taken or omitted to be taken in reliance on it, is prohibited and may be
unlawful. Any views expressed in this e-mail are those of the individual
sender, except where the sender specifically states them to be the views of
Clearstream International or of any of its affiliates or subsidiaries.

END OF DISCLAIMER
_______________________________________________
use-revolution mailing list
use-revolution at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the use-livecode mailing list