the inverse of the "owner" property

Dick Kriesel dick.kriesel at mail.com
Mon Oct 10 23:24:59 EDT 2005


Here¹s a virtual property that (I think) is the inverse of the ³owner²
property.  It has a strange name, based on the assertion that the opposite
of "owner" is "ownee."  Call it what you will...

The property works for me, but does anyone see trouble with it?

getProp ownees
  if first word of name of the target is "stack" then
    put the substacks of the target into tSubstacks
    if tSubstacks is empty then
      put the cardNames of the target into tOwnees
    else
      repeat for each line tSubstack in tSubstacks
        put the name of stack tSubstack & return after tOwnees
      end repeat
      put the cardNames of the target after tOwnees
    end if
  else
    put abbr id of the target into tOwner
    repeat with i = 1 to number of controls in tOwner
      if abbr id of the owner of control i of tOwner is tOwner then
        put name of control i of tOwner & return after tOwnees
      end if
    end repeat
    delete last char of tOwnees
  end if
  return tOwnees
end ownees

Thanks in advance for your consideration...

-- Dick





More information about the use-livecode mailing list