PostgreSQL on linux

Allen Morgan amorgan59 at nc.rr.com
Tue Nov 22 16:47:42 EST 2005


Hi,

My first post: I've tried my best to get the Linux engine to 
successfully hit PostgreSQL.  I put a libpq.so.2 into play as described 
back on Mar 1 to workaround the missing lib error, but get

hello world
found dbPostgreSQL.so
symbols 1082168400,1082168272,1082168368
called idcounterptr/work/revolution/Revolution-2.6/revolution.x86 
exiting on signal 11

from  this small startup:

#!/work/revolution/Revolution-2.6/revolution.x86
on  startup
      put "hello world"
      put 
revOpenDatabase("PostgreSQL","localhost","adatabase","adbuser","apassword")
end startup

as well as having standalones and the development environment itself 
crash when trying an equivalent connection in each.  I copied the 
supplied driver dbpostgresql.so to dbPostgreSQL.so, as rev seems to be 
looking for that specific case.  I have used $LD_LIBRARY_PATH to point 
to the database_driver, which it does seem to find.  I wonder if there 
are other environment variables  akin to the REV_GDK_PATH that 
facilitate db access.  My linux is Redhat 9 and my PostgreSQL is 7.3.2, 
but I've tried 8.0.1 and 8.1 too.

Does anyone have this working who would be willing to shoot me a few 
insights?

Best regards,

Allen Morgan







More information about the Use-livecode mailing list